[Löst] perl: warning: Setting locale failed.

Här ställer ni allmäna frågor kring Slackware Linux

Moderatorer: Nille, Minime, nomicon

Användarvisningsbild
MDKDIO
Kodnisse
Inlägg: 1014
Blev medlem: 21 apr 2005 08:24
Ort: Bollnäs

[Löst] perl: warning: Setting locale failed.

Inlägg av MDKDIO »

Ville testa lite (för mig) nya cmd's. Men stötte på patrull direkt :D

Slackware current

cmd jag körde:
sensors-detect

Och fick då till svar:
bash-5.0# sensors-detect
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = "en_US",
LC_ALL = (unset),
LC_COLLATE = "C",
LANG = "en_SE.UTF-8"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").

etc etc...

Trött som F, men sökte lite info, men nja. Inget direkt matnyttigt (jagar vidare i morgon)
Noterade dock att t.ex. via KDE (Plasma i mitt fall) -> System Settings -> Regional settings
Krashar (tips från LQ, ändra i dessa inställningarna...).
Hinner dock se något i stil med... There are no Additional languages available on this system...

Någon som stött på detta?

Redigerat:
Tydligen nån bug
https://alien.slackbook.org/blog/update ... ment-37223
Slackware 64-bit 14.2 (& Current) (Multilib) (desktop)
Slackware 64-bit 14.2 + Current (Laptop)
Slackware 64-bit 14.2 (Multilib) + Current (Plasma5) (Laptop)
Slackware 64-bit 14.2 (xfce) (MediaPC)

Linux Counter. User 267939

Användarvisningsbild
Nille
Guru
Inlägg: 1384
Blev medlem: 17 jun 2004 02:41

Re: perl: warning: Setting locale failed.

Inlägg av Nille »

en_SE.UTF-8 tycker jag låter som en udda locale, själv använder jag sv_SE.UTF-8
Varför använder du en_SE.UTF-8?
The more linux you go the slacker you get.

Användarvisningsbild
MDKDIO
Kodnisse
Inlägg: 1014
Blev medlem: 21 apr 2005 08:24
Ort: Bollnäs

Re: perl: warning: Setting locale failed.

Inlägg av MDKDIO »

Helt ärligt vet jag inte varför. Def inget jag konfigurerat medvetet IAF.
Den enda förklaringen jag kan ge, är att jag alltid kör Engelska med Regional Settings på Svenska.
(KDE plasma i current för tillfället).

Ska kolla inställningarna i mina laptop's vid tillfälle, se vad de "säger"...

Redigerat:
Fortfarande krash efter de senaste uppdateringarna installerade i dag, vet dock inte om Alien gjort några ändringar än...
Slackware 64-bit 14.2 (& Current) (Multilib) (desktop)
Slackware 64-bit 14.2 + Current (Laptop)
Slackware 64-bit 14.2 (Multilib) + Current (Plasma5) (Laptop)
Slackware 64-bit 14.2 (xfce) (MediaPC)

Linux Counter. User 267939

Användarvisningsbild
MDKDIO
Kodnisse
Inlägg: 1014
Blev medlem: 21 apr 2005 08:24
Ort: Bollnäs

Re: perl: warning: Setting locale failed.

Inlägg av MDKDIO »

Lite test...
Den ena laptop'n har korrekt inställningar men kör inte plasma (current, precis som min desktop).

Tidigare KDE versioner har en, per användare, konfigurationsfil som gör det möjligt att "gå runt" standard locale inställningarna. Samt krav för kde-l10n rel paket är installerat för det språk, den valuta etc man vill ha i KDE. Men plasma kör med något annat, och jag hittar det inte...

Nu är det inte så jätte viktigt att få detta att fungera, men man vill ju lära sig något också :)

Redigerat: ca 2 timmar senare...
Vore nog trots allt trevligt med en lösning på detta, då även Libreoffice "klagar" på locale settings... OM jag startar via konsollen.
Slackware 64-bit 14.2 (& Current) (Multilib) (desktop)
Slackware 64-bit 14.2 + Current (Laptop)
Slackware 64-bit 14.2 (Multilib) + Current (Plasma5) (Laptop)
Slackware 64-bit 14.2 (xfce) (MediaPC)

Linux Counter. User 267939

Användarvisningsbild
MDKDIO
Kodnisse
Inlägg: 1014
Blev medlem: 21 apr 2005 08:24
Ort: Bollnäs

Re: perl: warning: Setting locale failed.

Inlägg av MDKDIO »

Skam den som ger sig...

Jag redigerade ~/.config/plasma-localerc filen då den saknade en hel del info
Jag hade: (ingen aning om varifrån dessa värden kommer ifrån än)

Kod: Markera allt

[Formats]
LANG=en_SE.UTF-8

[Translations]
LANGUAGE=en_US
Och ändrade till:

Kod: Markera allt

[Formats]
LANG=en_US.utf8
LC_COLLATE=sv_SE.utf8
LC_MEASUREMENT=sv_SE.utf8
LC_MONETARY=sv_SE.utf8
LC_NUMERIC=sv_SE.utf8
LC_TIME=sv_SE.utf8
useDetailed=true

[Translations]
LANGUAGE=en_US
Loggade ut och in igen. Testade med libreoffice = inga felmeddelanden.
Testade med

Kod: Markera allt

bash-5.0# sensors-detect 
# sensors-detect version 3.6.0
# Board: ASUSTeK COMPUTER INC. A68HM-PLUS
# Kernel: 5.4.40 x86_64
# Processor: AMD A4-7300 APU with Radeon HD Graphics (21/19/1)
(yep, gammal burk...)
Slackware 64-bit 14.2 (& Current) (Multilib) (desktop)
Slackware 64-bit 14.2 + Current (Laptop)
Slackware 64-bit 14.2 (Multilib) + Current (Plasma5) (Laptop)
Slackware 64-bit 14.2 (xfce) (MediaPC)

Linux Counter. User 267939