nagra sma problem

Slackware på Laptop? Ställ era frågor här.

Moderatorer: Nille, Minime

eXpander
Hacker
Inlägg: 27
Blev medlem: 16 sep 2011 00:41

Re: nagra sma problem

Inlägg av eXpander »

Eller, om du bara använder ett program för HDMI, så kan du tvinga det programmet att använda snd_card_HDMI modulens medans resterande program och system använder snd_card_laptop.
inc
Hacker
Inlägg: 40
Blev medlem: 02 jan 2012 11:42

Re: nagra sma problem

Inlägg av inc »

om jag har förstått rätt så ska jag skapa en fil .asoundrc i min /home katalog och lägga in
pcm.snd_card_laptop {
type hw
card 0
device 0
}
pcm.snd_card_HDMI {
type hw
card 0
device 3
}

pcm.!default "snd_card_laptop"

det har jag gjort men inget ljud tyvär. det enda som har ändrats är att ett nivåreglage har försvunit från alsamix.

eXpander
Hacker
Inlägg: 27
Blev medlem: 16 sep 2011 00:41

Re: nagra sma problem

Inlägg av eXpander »

Något funkar iaf, alsamixer reagerar, det är alltid bra! :). För att komma åt reglaget ändrar du till följande:

Kod: Markera allt

pcm.snd_card_laptop {
type hw
card 0
device 0
}
pcm.snd_card_HDMI {
type hw
card 0
device 3
}


pcm.add_volume_control_to_laptop {
    type            softvol
    slave.pcm       "snd_card_laptop"
    control.name    "Laptop volume"
    control.card    0
}

pcm.!default "add_volume_control_to_laptop"
Om det nya regaglet "Laptop volume" inte ökar eller ger någon volym från alsamixern så vet jag tyvärr inte varför.
eXpander
Hacker
Inlägg: 27
Blev medlem: 16 sep 2011 00:41

Re: nagra sma problem

Inlägg av eXpander »

Ser också att du har pillat i ALSACONF,, se till att ta bort de ändringar du har gjort där så att det återgår till default-läge.
inc
Hacker
Inlägg: 40
Blev medlem: 02 jan 2012 11:42

Re: nagra sma problem

Inlägg av inc »

vad jag har bara kört alsaconf inte pillat i den (vad jag kommer i håg i alla fall) hur får jag den till defult :S
pcm.snd_card_laptop {
type hw
card 0
device 0
}
pcm.snd_card_HDMI {
type hw
card 0
device 3
}

pcm.!default "snd_card_laptop"

pcm.add_volume_control_to_laptop {
type softvol
slave.pcm "snd_card_laptop"
control.name "Laptop volume"
control.card 0
}

pcm.!default "add_volume_control_to_laptop"
så ser min .asound ut nu men det hände inget om jag tar all den nya koden så startar inte ens alsamixer.
eXpander
Hacker
Inlägg: 27
Blev medlem: 16 sep 2011 00:41

Re: nagra sma problem

Inlägg av eXpander »

Din /etc/modprobe.d/sound.conf bör innehålla det här:

# --- BEGIN: Generated by ALSACONF, do not edit. ---
# --- ALSACONF version 1.0.24.2 ---
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
# --- END: Generated by ALSACONF, do not edit. ---

sound.conf behövs egentligen inte i ditt fall ändå.

Hur som helst, vad får du för felmeddelande när du kör alsamixer från terminalen?
eXpander
Hacker
Inlägg: 27
Blev medlem: 16 sep 2011 00:41

Re: nagra sma problem

Inlägg av eXpander »

Nej, nej, så ska inte din .asounrdrc se ut, utan såhär:

pcm.snd_card_laptop {
type hw
card 0
device 0
}
pcm.snd_card_HDMI {
type hw
card 0
device 3
}


pcm.add_volume_control_to_laptop {
type softvol
slave.pcm "snd_card_laptop"
control.name "Laptop volume"
control.card 0
}

pcm.!default "add_volume_control_to_laptop"


Ta alltså bort pcm.!default "snd_card_laptop" från din .asoundrc.
inc
Hacker
Inlägg: 40
Blev medlem: 02 jan 2012 11:42

Re: nagra sma problem

Inlägg av inc »

Ok :P ja nu funkar det eller jag har fått ett nytt reglage men inget ljud :/
och min sound.conf inehåller bara det som du skrev
när jag kör alsaconf så står det att den ska conf intel corporation 6 series Chipset family hige definition A

som jag sedan inte ser någonstans är det så att det inte finns drivare för det chipet?

#/sbin/modprobe pcspkr
ska den vara aktiverad ?
eXpander
Hacker
Inlägg: 27
Blev medlem: 16 sep 2011 00:41

Re: nagra sma problem

Inlägg av eXpander »

Posta din cat /proc/asound/modules och cat /proc/asound/cards.

Och check om modulen är laddad via lsmod. Pasta även din lspci.
Senast redigerad av 1 eXpander, redigerad totalt 9 gånger.
eXpander
Hacker
Inlägg: 27
Blev medlem: 16 sep 2011 00:41

Re: nagra sma problem

Inlägg av eXpander »

Posta även din:

/var/log/messages

och

/var/log/syslog
inc
Hacker
Inlägg: 40
Blev medlem: 02 jan 2012 11:42

Re: nagra sma problem

Inlägg av inc »

Så ja jag har dock upptäckt att jag facktiskt har ljud men bara genom hörlurar :S men i alla fall något



:~$ cat /proc/asound/modules
0 snd_hda_intel


:~$ cat /proc/asound/cards
0 [PCH ]: HDA-Intel - HDA Intel PCH
HDA Intel PCH at 0xd1c00000 irq 48


lspci
00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation 2nd Generation Core Processor Family PCI Express Root Port (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
00:16.0 Communication controller: Intel Corporation 6 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB Controller: Intel Corporation 6 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 6 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 6 Series Chipset Family PCI Express Root Port 1 (rev b4)
00:1c.1 PCI bridge: Intel Corporation 6 Series Chipset Family PCI Express Root Port 2 (rev b4)
00:1c.2 PCI bridge: Intel Corporation 6 Series Chipset Family PCI Express Root Port 3 (rev b4)
00:1c.3 PCI bridge: Intel Corporation 6 Series Chipset Family PCI Express Root Port 4 (rev b4)
00:1d.0 USB Controller: Intel Corporation 6 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation HM65 Express Chipset Family LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 6 Series Chipset Family 6 port SATA AHCI Controller (rev 04)
00:1f.3 SMBus: Intel Corporation 6 Series Chipset Family SMBus Controller (rev 04)
01:00.0 VGA compatible controller: nVidia Corporation Device 0df4 (rev a1)
02:00.0 Ethernet controller: Atheros Communications Device 1083 (rev c0)
03:00.0 Network controller: Atheros Communications Inc. AR9287 Wireless Network Adapter (PCI-Express) (rev 01)
04:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. Device 5209 (rev 01)
05:00.0 USB Controller: NEC Corporation uPD720200 USB 3.0 Host Controller (rev 04)


lsmod
Module Size Used by
snd_seq_dummy 1487 0
snd_seq_oss 29088 0
snd_seq_midi_event 5620 1 snd_seq_oss
snd_seq 50914 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device 5353 3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss 38869 0
snd_mixer_oss 15145 1 snd_pcm_oss
ipv6 275869 24
cpufreq_ondemand 9172 4
acpi_cpufreq 5761 1
freq_table 2443 2 cpufreq_ondemand,acpi_cpufreq
mperf 1203 1 acpi_cpufreq
lp 9553 0
ppdev 5837 0
parport_pc 20926 0
parport 29031 3 ppdev,lp,parport_pc
fuse 66755 1
snd_hda_codec_hdmi 23280 1
snd_hda_intel 21819 2
snd_hda_codec 71008 2 snd_hda_codec_hdmi,snd_hda_intel
ath9k 87760 0
snd_hwdep 6134 1 snd_hda_codec
uvcvideo 62119 0
snd_pcm 72045 4 snd_pcm_oss,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec
mac80211 209482 1 ath9k
nouveau 652699 0
i915 459084 2
snd_timer 18937 2 snd_seq,snd_pcm
ath9k_common 1949 1 ath9k
ath9k_hw 285722 2 ath9k,ath9k_common
snd 55844 15 snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_timer
ath 14104 2 ath9k,ath9k_hw
videodev 64720 1 uvcvideo
ttm 54471 1 nouveau
psmouse 55736 0
cfg80211 146022 3 ath9k,mac80211,ath
drm_kms_helper 27171 2 nouveau,i915
rtc_cmos 9374 0
soundcore 5585 1 snd
drm 177095 5 nouveau,i915,ttm,drm_kms_helper
sparse_keymap 2992 0
v4l2_compat_ioctl32 6812 1 videodev
i2c_i801 8174 0
rtc_core 16515 1 rtc_cmos
sg 25371 0
intel_agp 10800 1 i915
atl1c 32580 0
snd_page_alloc 7145 2 snd_hda_intel,snd_pcm
serio_raw 4382 0
rfkill 15634 2 cfg80211
processor 24354 1 acpi_cpufreq
evdev 9457 16
i2c_algo_bit 5264 2 nouveau,i915
battery 10890 0
intel_gtt 14633 3 i915,intel_agp
i2c_core 19577 7 nouveau,i915,videodev,drm_kms_helper,drm,i2c_i801,i2c_algo_bit
rtc_lib 2322 1 rtc_core
video 11411 2 nouveau,i915
ac 3289 0
wmi 8595 0
agpgart 27184 4 ttm,drm,intel_agp,intel_gtt
thermal_sys 14269 2 processor,video
button 5021 2 nouveau,i915
hwmon 1473 1 thermal_sys
loop 16719 0
ext4 336773 2
mbcache 5682 1 ext4
jbd2 65889 1 ext4
xhci_hcd 64417 0
ehci_hcd 40035 0
usbhid 35371 0
hid 77213 1 usbhid
eXpander
Hacker
Inlägg: 27
Blev medlem: 16 sep 2011 00:41

Re: nagra sma problem

Inlägg av eXpander »

Ok, antingen använder du en kernel som ger felaktiga parametrar till ditt ljudkort, så en lösning är att prova upgradera din kernel-version.

Men först, kolla vad det är för codecs som egentligen används genom att köra detta:

cat /proc/asound/card0/codec#0 | grep Codec
Användarvisningsbild
Nille
Guru
Inlägg: 1409
Blev medlem: 17 jun 2004 02:41

Re: nagra sma problem

Inlägg av Nille »

Bara som ett tips så finns alsa-info.sh för att samla nödvändig information.

Kod: Markera allt

wget www.alsa-project.org/alsa-info.sh
sh alsa-info.sh
The more linux you go the slacker you get.
inc
Hacker
Inlägg: 40
Blev medlem: 02 jan 2012 11:42

Re: nagra sma problem

Inlägg av inc »

:~# cat /proc/asound/card0/codec#0 | grep Codec
Codec: Conexant ID 506c



Kernel release: 2.6.38.4 -->har ju stöd enligt vad jag har läst i alla fall.
!!Loaded ALSA modules
!!-------------------
snd_hda_intel

!!Sound Servers on this system
!!----------------------------
ESound Daemon:
Installed - Yes (/usr/bin/esd)
Running - No

!!Soundcards recognised by ALSA
!!-----------------------------
0 [PCH ]: HDA-Intel - HDA Intel PCH
HDA Intel PCH at 0xd1c00000 irq 48
!!PCI Soundcards installed in the system
!!--------------------------------------
00:1b.0 Audio device: Intel Corporation 6 Series Chipset Family High Definition Audio Controller (rev 04)
!!PCI Soundcards installed in the system
!!--------------------------------------
00:1b.0 Audio device: Intel Corporation 6 Series Chipset Family High Definition Audio Controller (rev 04)

!!Advanced information - PCI Vendor/Device/Subsystem ID's
!!--------------------------------------------------------
00:1b.0 0403: 8086:1c20 (rev 04)
Subsystem: 1025:055b
!!Module: snd_hda_intel
bdl_pos_adj : 1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1
enable : Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y,Y
enable_msi : -1
id : (null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),$
index : -1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1
model : (null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(nul$
patch : (null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(null),(nul$
position_fix : 0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0
probe_mask : -1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1,-1
probe_only : 0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0
single_cmd :

ok jag vet inte vad som är viktigt i den filen men detta kanske är till någon hjälp. :doubt:

ser att det finns fler som har samma problem med samma codec samt intel series 6 kort men det verkar finnas en patch som kan funka :/ men för ubuntu det konstiga är att ingen får ljud ens i hörlurarna men det får ju faktiskt jag humm.

slutsatsen verkar ju dock vara att vänta tills det finns en kernel över 2.6.29 (som inte heller verkar funka med detta kort) och jag vet inte om jag skulle våga ens att pröva kernel-3.2 en sådana installation verkar aningen svår :/

yterligare en fråga ./ när systemet "freezes" vart kan jag läsa vad som hände ? kollade i /var/log men hittade inget händer några gånger om dagen trode först det var när datorn gick ner i hibernat men jag stängde ner det men problemet kvarstår.
eXpander
Hacker
Inlägg: 27
Blev medlem: 16 sep 2011 00:41

Re: nagra sma problem

Inlägg av eXpander »

Jag tror inte det går att göra så mycket mer än att försöka upgradera ALSA samt kernel. Enligt denna länk iaf:

http://lkml.indiana.edu/hypermail/linux ... 00057.html

så infördes en ny patch för Conexant codec 506 i kernel-versionen 2.6.39 stable. Sedan av att döma flera buggar (Conexant codec 506) i Ubuntu-forum så infördes ytterliggare patch-fixar för den senare 3.x.x-kerneln.

Jag har gjort ett eget script som (halv)-automatiskt upgraderar kerneln. Den följer stegen som anges http://alien.slackbook.org/dokuwiki/dok ... elbuilding av AlienBOB.

Länk till mitt script: http://dl.dropbox.com/u/40050690/kernel_upgrade.sh

Du ska ändra raderna:
xauth merge ~USERNAME/.Xauthority
export DISPLAY=YOURDISPLAY
echo root = /YOURBOOTPARTITION >> /etc/lilo.conf

så att du anger ditt username, DISPLAY samt namnet på din rootpartition (det står mer om detta i filen). Du gör filen exekverbar med chmod +x såklart. Sedan kan du ladda ned den stabila kerneln 3.1.8 och testa. Du kör filen med

./kernel_upgrade.sh linux-archive-filen

Du kommer få en massa förfrågninar, där är det bara att trycka på ENTER-knappen. Sedan kommer ett GUI att dyka upp där du kan göra ytterliggare inställningar, de viktigaste är att du bockar för följande:

RTC (Real Time Clock)
Processor type and features” > “Preemption model” > “Preemptible kernel > “low-latency”
Checka så att rätt CPU typ anges här: “Processor type and features”
Samt kom ihåg LOCALNAMNET från General setup” > “Local version. Oftast brukar den heta "smp" eller liknande.

På slutet, när upgraderingen är klart skriver du följande manuellt:

cp -a /etc/rc.d/rc.modules-DIN-GAMLA-KERNEL-VERSION /etc/rc.d/rc.modules-3.1.8-LOCALNAMNET

Hoppas det vill sig väl...