Ingen skärm hittas... [Löst]

Frågor om X.ORG, KDE, Gnome osv kan ställas här.

Moderatorer: Nille, Minime, nomicon

berraf
Lärling
Inlägg: 77
Blev medlem: 31 jul 2004 11:04

Ingen skärm hittas... [Löst]

Inlägg av berraf »

Efter installtion av Slackware på en äldre dator får jag inte igång X.
Har kört xorgconfig ett flertal gånger med mängder av olika inställningar men utan positivt resultat. Nån enstaka gång funkar det men då bara i nåt basic-läge där inte ens KDE:s inloggningsruta får plats på skärmen.
Felmeddelandet jag får säger att det inte finns stöd för t.ex 16bitar alternativt att ingen skärm hittas.

Märkligt är att jag prövat installera både Xandros och Mandrake och då funkar det. Har tittat i deras xconfig-filer och försökt kopiera värdena men utan framgång.

Min grafikdriver är i810, åtminstone säger Xandros det.

Som alltid är jag tacksam för hjälp....
Senast redigerad av 1 berraf, redigerad totalt 22 gånger.

jenso
Gud
Inlägg: 1823
Blev medlem: 08 okt 2003 10:35

Inlägg av jenso »

Vad säger cat /proc/pci
En länk till min xorg.conf, för ett i810
http://www.slackware.se/jens/doc/xorg.c ... kware-i810

/Jens

berraf
Lärling
Inlägg: 77
Blev medlem: 31 jul 2004 11:04

Inlägg av berraf »

Hur gör jag för att se hela utmatningen av cat /proc/pci?
Nu bläddrar den förbi och jag ser bara slutet av den...

Kan jag redigera xorgconf manuellt från konsollen? I så fall, hur gör jag?

Det står i felmeddelandet att "AGP GART support is not available"
Betyder det att det har blivit nåt fel i kärnan vid installation?

jenso
Gud
Inlägg: 1823
Blev medlem: 08 okt 2003 10:35

Inlägg av jenso »

Shift+PageUp/PageDown. Eller cata till en fil och lessa.
cat /proc/pci > pci.txt, eller så.
Redigera med antingen vim eller pico, om du har Pine installerat.
I annat fall finns "nano" tillgänlig.
http://www.slackware.se/jens/adm/nano-1 ... 86-1jo.tgz för 10.2
http://www.slackware.se/jens/adm/nano-cvs-i486-1jo.tgz för 10.1
http://www.slackware.se/jens/adm/slack- ... i486-2.tgz för 10.0
Använd "wget".
wget URL

/Jens

Gäst

Inlägg av Gäst »

Det står i felmeddelandet att "AGP GART support is not available"
Betyder det att det har blivit nåt fel i kärnan vid installation?
Nej, men tydligen laddas inte agpgart, prova (som root)..

#modprobe agpgart
..sedan kollar du med..

#lsmod
..för att se vilka moduler som laddats, för mig är det både
agpgart, intel_agp samt drm
..som du kanske också måste "modprobe".

Kolla också din /etc/rc.d/rc.modules..
### AGP (Accelerated Graphics Port) GART support ###
# This module takes care of programming the GART (part of your motherboard's
# chipset that handles gathering data from memory and passing it to the
# card) and enables faster AGP transfers. The AGP GART module is required
# to use AGP features of your 3D rendering video card. You'll need this to
# use XFree86's direct rendering support, for example.
/sbin/modprobe agpgart
..så ska den laddas vid uppstarten.

/Håkan

Gäst

Inlägg av Gäst »

Anonymous skrev:
Det står i felmeddelandet att "AGP GART support is not available"
Betyder det att det har blivit nåt fel i kärnan vid installation?
Nej, men tydligen laddas inte agpgart, prova (som root)..

#modprobe agpgart
..sedan kollar du med..

#lsmod
..för att se vilka moduler som laddats, för mig är det både
agpgart, intel_agp samt drm
..som du kanske också måste "modprobe".

Kolla också din /etc/rc.d/rc.modules..
### AGP (Accelerated Graphics Port) GART support ###
# This module takes care of programming the GART (part of your motherboard's
# chipset that handles gathering data from memory and passing it to the
# card) and enables faster AGP transfers. The AGP GART module is required
# to use AGP features of your 3D rendering video card. You'll need this to
# use XFree86's direct rendering support, for example.
/sbin/modprobe agpgart
..så ska den laddas vid uppstarten.
/Håkan
Ps. Här har du en introduktion till texteditorn "pico"..
http://se.linux.org/dokumentation/artik ... pico_HOWTO

hakan
Hedersmedlem
Inlägg: 811
Blev medlem: 15 okt 2003 06:31
Ort: Lidingö

Inlägg av hakan »

17 också jag glömde logga in ..båda gångerna.. :oops:
Någon kan väl "städa"..

/Håkan

berraf
Lärling
Inlägg: 77
Blev medlem: 31 jul 2004 11:04

Inlägg av berraf »

#modprobe agpgart ger ingen utmatning alls
#modprobe intel_agp säger att modulen inte finns. Likadant med drm
#lsmod visar att agpgart finns

sbin/modprobe agpgart finns i /etc/rc.d/rc.modules

Hur går jag vidare?
Tacksam för alla hjälpsamma råd....

jenso
Gud
Inlägg: 1823
Blev medlem: 08 okt 2003 10:35

Inlägg av jenso »

Testa lite olika varianer och klistra in.

Kod: Markera allt

[hugin:jensa:~]
> grep agp /etc/rc.d/rc.modules <---- Vilket du redan konstaterat.
/sbin/modprobe agpgart
[hugin:jensa:~]
> dmesg | grep i810
agpgart: Detected an Intel i810 E Chipset.
i810_rng hardware driver 0.9.8 loaded
[hugin:jensa:~]
> dmesg | grep agpgart
Linux agpgart interface v0.99 (c) Jeff Hartmann
agpgart: Maximum main memory to use for agp memory: 148M
agpgart: Detected an Intel i810 E Chipset.
agpgart: detected 4MB dedicated video ram.
agpgart: AGP aperture is 64M @ 0xe4000000
[hugin:jensa:~]
> dmesg | grep Intel  
CPU: Intel Celeron (Coppermine) stepping 06
mtrr: detected mtrr type: Intel
Transparent bridge - Intel Corp. 82801AA PCI Bridge
agpgart: Detected an Intel i810 E Chipset.
[hugin:jensa:~]
/Jens

hakan
Hedersmedlem
Inlägg: 811
Blev medlem: 15 okt 2003 06:31
Ort: Lidingö

Inlägg av hakan »

Först av allt..slarvigt av mig.. du har naturligtvis 2.4-kärnan och då har du bara agpgart (mitt var med 2.6).

Den goda nyheten är att har du fått det att fungera med andra linuxdistar så kommer det att fungera med Slack också.. :)..däremot kan det ta lite tid eftersom jag förstår att det är svårt att "klippa och klistra" när du bara kommer in i "textläge".

Vad har du för skärm? Vet du "horisontell och vertikal sync"?

Jens och jag har inte exakt samma "i810", men får du något liknande hans eller mitt när du testar hans kommandon?

Mina värden..
#dmesg | grep i810
agpgart: Detected an Intel i810 Chipset.
i810_rng: RNG not detected
[drm] Initialized i810 1.2.1 20020211 on minor 0
#dmesg | grep agpgart
Linux agpgart interface v0.99 (c) Jeff Hartmann
agpgart: Maximum main memory to use for agp memory: 202M
agpgart: Detected an Intel i810 Chipset.
agpgart: AGP aperture is 64M @ 0xd0000000
#dmesg | grep Intel
CPU: Intel Celeron (Coppermine) stepping 0a
mtrr: detected mtrr type: Intel
Transparent bridge - Intel Corp. 82801AA PCI Bridge
agpgart: Detected an Intel i810 Chipset.
Hmm..funderar..såvida du inte har en väldigt gammal skärm borde (när du kör #xorgconfig och kommer till "bildskärmen") alt. 5,6 eller 7 fungera, glöm inte att svara "n" när du tillfrågas om du vill ha "viritual screen". det blir naturligtvis lättare om du kommer in i X och kan "klippa och klistra" till oss.

/Håkan

berraf
Lärling
Inlägg: 77
Blev medlem: 31 jul 2004 11:04

Inlägg av berraf »

prövade gång på gång men det funka inte så jag installera om Slack.
Det funkade inte heller. Likadant, att X inte starta...
MEN, nu hjälpte det att ändra i xorgconfig.
Så nu fungerar det.

Tack för all hjälp, men vad kunde vart fel?

jenso
Gud
Inlägg: 1823
Blev medlem: 08 okt 2003 10:35

Inlägg av jenso »

Svårt att säga om du inte säger vad du gjort;

/Jens