PHP 7.3.13 i Slackware 14.2

PHP kan diskuteras här.

Moderatorer: Nille, Minime

Användares profilbild
MDKDIO
Kodnisse
Poster: 956
Blev medlem: 21 Apr 2005 08:24
Ort: Bollnäs

PHP 7.3.13 i Slackware 14.2

Posta av MDKDIO »

Efter X antal svordommar och xx antal försök...
Så fick jag till det, PHP 7.3.13 i Slackware 14.2

Tankade ned php.SlackBuild incl de övriga filerna (utom php-7.4.1.tar.xz och php-7.4.1.tar.xz.asc)
till mapp lokalt på maskin (/home/username/php).

Samt en kopia av alpin till /home/username/alpin)

pcre Körde jag med den version som 14.2 har (pcre-8.43) då php-7.3.13 inte klagade...

Redigerat: Uppgraderade PCRE (trader) till 0.5.0. Ok

Sedan krävdes lite libs ifrån slackbuilds.org:
argon2 (ej senaste versionen dock) Redigerat: Nu är det senaste versionen 2020-02-28 /J
libedit (Valde att hämta 20191231 versionen)
libsodium

Kompilerade och såg Leksand spöa Oskarshamn under tiden...
Kopierade php.ini, httpd.conf, httpd-vhost.conf till backup
Uppgraderade och såg glad ut :)

Kontrollerade att alla moduler laddades ok.

OBS!
Använd mod_php.conf.new och inte den gamla mod_php.conf filen.
Samma sak med php.ini, använd php.ini.new

Tror jag fått med alla steg...
/J

Redigerat: Stött på ett problem. Saknar extension gd.so av någon anledning...
Slackware 64-bit 14.2 (& Current) (Multilib) (desktop)
Slackware 64-bit 14.2 + Current (Laptop)
Slackware 64-bit 14.2 (Multilib) + Current (Plasma5) (Laptop)
Slackware 64-bit 14.2 (xfce) (MediaPC)

Linux Counter. User 267939

Användares profilbild
MDKDIO
Kodnisse
Poster: 956
Blev medlem: 21 Apr 2005 08:24
Ort: Bollnäs

Re: PHP 7.3.13 i Slackware 14.2

Posta av MDKDIO »

Tills vidare...
Glöm förra posten. Jag får inte det att fungera 100%, dels pga versions fel i div *.conf filer

Jobbar på saken...
Slackware 64-bit 14.2 (& Current) (Multilib) (desktop)
Slackware 64-bit 14.2 + Current (Laptop)
Slackware 64-bit 14.2 (Multilib) + Current (Plasma5) (Laptop)
Slackware 64-bit 14.2 (xfce) (MediaPC)

Linux Counter. User 267939

Användares profilbild
MDKDIO
Kodnisse
Poster: 956
Blev medlem: 21 Apr 2005 08:24
Ort: Bollnäs

Re: PHP 7.3.13 i Slackware 14.2

Posta av MDKDIO »

Jag kastade in handduken. Installerade Debian 10.x i stället, då det inte fungerar med Slackware current för det jag använder maskinen till.

Men det hade varit kul och veta hur man löser detta till en annan gång...

/J
Slackware 64-bit 14.2 (& Current) (Multilib) (desktop)
Slackware 64-bit 14.2 + Current (Laptop)
Slackware 64-bit 14.2 (Multilib) + Current (Plasma5) (Laptop)
Slackware 64-bit 14.2 (xfce) (MediaPC)

Linux Counter. User 267939

Användares profilbild
Nille
Guru
Poster: 1382
Blev medlem: 17 Jun 2004 02:41

Re: PHP 7.3.13 i Slackware 14.2

Posta av Nille »

Det borde inte vara några större problem att installera senare versioner av php.
Nu är det väldigt länge sedan jag lekte med php men förr var det vanligt att ha flera versioner samtidigt så man kunde testa en annan version samtidigt som servern körde på som vanligt.
The more linux you go the slacker you get.

Användares profilbild
MDKDIO
Kodnisse
Poster: 956
Blev medlem: 21 Apr 2005 08:24
Ort: Bollnäs

Re: PHP 7.3.13 i Slackware 14.2

Posta av MDKDIO »

Tjena Nille!
Nej det är inte senare versioner av php som är problemet för mig, utan det är current som kör en för ny version av PHP :)

Jag "jobbar" med Drupal CMS, och 7.4.x av PHP är för ny...
Fungerar dock med 7.3.x utan problem.

Men nu har jag stött på patrull i Debian också, dock inte PHP relaterat. Men rel till composer.

Jag ska kolla om AlienBOB har någon current image med äldre PHP version. Funkar detta så svartlistar jag php tills Drupal löst problemet... :)

/J
Slackware 64-bit 14.2 (& Current) (Multilib) (desktop)
Slackware 64-bit 14.2 + Current (Laptop)
Slackware 64-bit 14.2 (Multilib) + Current (Plasma5) (Laptop)
Slackware 64-bit 14.2 (xfce) (MediaPC)

Linux Counter. User 267939

Användares profilbild
Nille
Guru
Poster: 1382
Blev medlem: 17 Jun 2004 02:41

Re: PHP 7.3.13 i Slackware 14.2

Posta av Nille »

Om du valt att arbeta med drupal så värderar du inte din egen tid och du lär plöja ner mycket mer tid än du anar.
The more linux you go the slacker you get.

Användares profilbild
MDKDIO
Kodnisse
Poster: 956
Blev medlem: 21 Apr 2005 08:24
Ort: Bollnäs

Re: PHP 7.3.13 i Slackware 14.2

Posta av MDKDIO »

Jo jag har märkt det :)
Men då jag inte kan få till ett slackware paket för 7.3.x version av php så ...

Har ingen aning om hur jag ska få fixat ett paket, antingen för 14.2 (helst) eller current.
Current kör 7.4.2 och drupal funkar inte med 7.4 än.

Redigerat:
Ska lägga till att jag löste problemet med composer i går "klockan sent" :)
Slackware 64-bit 14.2 (& Current) (Multilib) (desktop)
Slackware 64-bit 14.2 + Current (Laptop)
Slackware 64-bit 14.2 (Multilib) + Current (Plasma5) (Laptop)
Slackware 64-bit 14.2 (xfce) (MediaPC)

Linux Counter. User 267939

Användares profilbild
MDKDIO
Kodnisse
Poster: 956
Blev medlem: 21 Apr 2005 08:24
Ort: Bollnäs

Re: PHP 7.3.13 i Slackware 14.2

Posta av MDKDIO »

Har du Nille, eller någon annan tips på hur jag fixar SlackBuild för PHP 7.2 eller 7.3 så är jag tacksam för dessa tips :)

Jag har testat med:
Pat's slackbuild för 7.1 här med 7.2 & 7.3
Dessutom med slackbuild från 14.2 (5.6.40)

Inget av dessa vill fungera. Och ja, jag har tagit ner alpine också.
Slackware 64-bit 14.2 (& Current) (Multilib) (desktop)
Slackware 64-bit 14.2 + Current (Laptop)
Slackware 64-bit 14.2 (Multilib) + Current (Plasma5) (Laptop)
Slackware 64-bit 14.2 (xfce) (MediaPC)

Linux Counter. User 267939

Användares profilbild
Nille
Guru
Poster: 1382
Blev medlem: 17 Jun 2004 02:41

Re: PHP 7.3.13 i Slackware 14.2

Posta av Nille »

Vad är det som inte fungerar när du försöker installera php 7.3?
Jag är även lite nyfiken vad du ska använda drupal till?
Drupal har sina användningsområden men jag är tveksam till att du skulle jobba med ett sådant.
The more linux you go the slacker you get.

Användares profilbild
MDKDIO
Kodnisse
Poster: 956
Blev medlem: 21 Apr 2005 08:24
Ort: Bollnäs

Re: PHP 7.3.13 i Slackware 14.2

Posta av MDKDIO »

Det som inte fungerar, är att php saknar en mängd med moduler. Dessa moduler finns med i de paket som Pat skapar för oss i respektive version (t. ex. 7.4.2 som current har).
Moduler som på rak arm, saknas är: gd, zip. För att nämna några.

I övrigt tycks php fungera ok vid installationen jag gjorde i 14.2. Men gav upp då moduler saknades.

Så till Drupal...
Huvudanledningen till att jag vill köra Drupal, är för att lära mig det. Och för att detta då ska ha någon mening, så skapar jag en media databas (en helt ny, den gamla är 10+ år gammal).

I denna databas så använder jag en hel mängd med "cross references", t. ex. så kan en person
(artist, skådespelare, eller annat) vara medlem i flera band, vara producent åt annan artist, eller skådespelare i en film/tv-serie.
Eller en producent kan ha producerat en film och X antal musik album, osv..

Och allt material i databasen när det gäller filmer, musik, är enbart sådant jag själv har
(Så se det som en databas över den media jag har i form av, vinyl, CD, DVD, Blu-Ray etc etc...)

Jag har fått det mesta att fungera så som jag vill, men det saknas lite funktioner och en layout
(vilket jag inte ens har börjat med än).

Sen vet inte jag vilka användningsområden som drupal passar bäst för, men jag fick tips om att testa drupal av en person, då jag talade om att jag skulle göra en ny media databas
(personen i fråga var med redan då jag gjorde den förra versionen).
Slackware 64-bit 14.2 (& Current) (Multilib) (desktop)
Slackware 64-bit 14.2 + Current (Laptop)
Slackware 64-bit 14.2 (Multilib) + Current (Plasma5) (Laptop)
Slackware 64-bit 14.2 (xfce) (MediaPC)

Linux Counter. User 267939

Användares profilbild
MDKDIO
Kodnisse
Poster: 956
Blev medlem: 21 Apr 2005 08:24
Ort: Bollnäs

Re: PHP 7.3.13 i Slackware 14.2

Posta av MDKDIO »

Det ser ut som om jag får köra med debian ett tag till då drupal 8.8.x fortfarande inte supporterar PHP 7.4.x

Men jag noterade att det händer saker rel till PHP 7.4 så sent som i går iaf.
Så med lite tur så blir det slackware snart igen :badgrin:
Slackware 64-bit 14.2 (& Current) (Multilib) (desktop)
Slackware 64-bit 14.2 + Current (Laptop)
Slackware 64-bit 14.2 (Multilib) + Current (Plasma5) (Laptop)
Slackware 64-bit 14.2 (xfce) (MediaPC)

Linux Counter. User 267939

Användares profilbild
MDKDIO
Kodnisse
Poster: 956
Blev medlem: 21 Apr 2005 08:24
Ort: Bollnäs

Re: PHP 7.3.13 i Slackware 14.2

Posta av MDKDIO »

Skam den som ger sig...

Testade igen, men denna gång med current och PHP 7.3.15
Jag hämtade helt sonika ner allt som jag behövde ifrån slackware.com, redigerade lite ang php version. Kompilerade och "uppgraderade" till 7.3.15 ISTF 7.4.3

GD tycks nu fungera IAF :)
Återstår att se om övriga extensions också fungerar...

Ska göra ett nytt försök under 14.2 med php 7.2.x under helgen då jag måste få till detta :)
Slackware 64-bit 14.2 (& Current) (Multilib) (desktop)
Slackware 64-bit 14.2 + Current (Laptop)
Slackware 64-bit 14.2 (Multilib) + Current (Plasma5) (Laptop)
Slackware 64-bit 14.2 (xfce) (MediaPC)

Linux Counter. User 267939

Användares profilbild
MDKDIO
Kodnisse
Poster: 956
Blev medlem: 21 Apr 2005 08:24
Ort: Bollnäs

Re: PHP 7.3.13 i Slackware 14.2

Posta av MDKDIO »

So far so good....

14.2 med php 7.2.28 kompilerad och uppgraderad...

Testing testing...

Redigerat:
Gick som vanligt åt skogen... Saknas moduler/extensions :(

Redigering 2:
Efter att ha läst igenom php.ini-development.diff filen, så noterade jag att moduler/extensions INTE använda extension=gd, utan ext=gd. Samma sak med extension=zip -> ext=zip
; 'extension='php_<ext>.dll') is supported for legacy reasons and may be
; deprecated in a future PHP major version. So, when it is possible, please
; move to the new ('extension=<ext>) syntax.
Så installationen av drupal 8 då...

Redigerat 3:
Nya problem :)
memory_limit i php.ini fick ändras till -1

Redigerat 4:
Men nu så, efter lite brainstorm med minime, så kom vi båda fram till att respektive php version,
har olika sätt sätt att inkludera modulerna (eller kompilera modulerna, om man så vill).

I 14.2 med php 7.2.28,
php.SlackBuild för current:
--with-zip=shared \ ändrad till --enable-zip=shared \
--enable-gd=shared \ ändrad till --with-gd=shared \

I current och php 7.3.15
--with-zip=shared \ ändrad till --enable-zip=/usr \
Lägga till raden --without-libzip \

--with-libxml \ ändrad till --enable-libxml \
Lägga till raden --enable-xml \

Jag tror jag fått med alla ändringar...

Redigerat 5:
Nu funkade Drupal i 14.2 (med memory_limit = -1)
Slackware 64-bit 14.2 (& Current) (Multilib) (desktop)
Slackware 64-bit 14.2 + Current (Laptop)
Slackware 64-bit 14.2 (Multilib) + Current (Plasma5) (Laptop)
Slackware 64-bit 14.2 (xfce) (MediaPC)

Linux Counter. User 267939

Skriv Svar