Uppgradera till PHP5

PHP kan diskuteras här.

Moderatorer: Nille, Minime

the1980man
Guru
Poster: 67
Blev medlem: 31 Jan 2006 21:03

Uppgradera till PHP5

Posta av the1980man » 22 Apr 2006 20:07

Kanske lite 'lat' fråga, men hur gör man för att på enklase sätt uppgradera en Apache-server
från PHP4-stöd till PHP5-stöd?

BigDuke6
Allsmäktig
Poster: 223
Blev medlem: 09 Mar 2005 22:34
Ort: Stockholm, Sweden

Posta av BigDuke6 » 22 Apr 2006 20:27

Kan inte svära på att det är enklaste sättet men det finns en del intressanta paket här
http://www.linuxpackages.net/

Hurricane
Guru
Poster: 53
Blev medlem: 15 Okt 2003 22:50
Ort: GBG
Kontakt:

Posta av Hurricane » 23 Apr 2006 00:48

Du kan även dra ner PHP5 paket från ftp://ftp.slackware.no/pub/linux/slackw ... php-5.1.2/

och sen ändra konf-filen till apache för att ladda php5 modulen istället för php4.
Antingen i mod_php.conf eller i httpd.conf, själv laddar jag modulen från mod_php.conf och då ser min rad för att ladda modulen som följer.

Kod: Välj alla

LoadModule php5_module lib/apache2/libphp5.so
istället för som det är när man laddar php4 modulen

Kod: Välj alla

LoadModule php4_module lib/apache2/libphp4.so
då använder jag apache 2.0.53 men använder du apache 1.X.XX så laddar du modulen med följande rad

Kod: Välj alla

LoadModule php5_module libexec/apache/libphp5.so
Hoppas det var utförligt. :D
MVH Hurricane.
-------------------------
Asus P4C800-E Deluxe
P4 3.00 @ 3.45GHz
6848.51 Bogomips
1GB Ram
XFX Geforce4 TI4800SE
Slackware Current, Fluxbox
Linux Registred User #349687

Skriv Svar