Det blir tyvärr ingen kernel 4.4.284 paket för Slackware 14.2

Moderatorer: Nille, Minime, nomicon

Användarvisningsbild
Minime
Labrat
Inlägg: 573
Blev medlem: 14 okt 2005 14:27
Ort: Loos

Det blir tyvärr ingen kernel 4.4.284 paket för Slackware 14.2

Inlägg av Minime »

Tyvärr blir det inga mer paket för Slackware 14.2
Mitt system krashade och jag orkade inte patcha upp allt igen, då GCC är så gammalt så man knappt kan bygga något överhuvudtaget utan att stöta på problem så har jag givit upp och uppgraderat systemet till Slackware-Current (15.0) istället.

GCC är för ny i Slackware-Current, så jag kan inte bygga kernel paketen för Slackware 14.2 längre.
Beklagar.
Senast redigerad av 1 MDKDIO, redigerad totalt 23 gånger.
Anledning: Fel kernel version /J

Raspberry Pi 4B 4 Gb RAM Slackware Arm Current
Server EeeBox Atom 1.6 GHz 1.5 Gb RAM Slackware Current x64bit
Asus Rog Strix AMD Ryzen 5 3.6 GHz 16 Gb RAM Slackware Current multilib
Miraclebox Premium Twin HD - Openvix 5.2.040 (Neotion CI+ CA-modul)
Användarvisningsbild
MDKDIO
Kodnisse
Inlägg: 1474
Blev medlem: 21 apr 2005 08:24
Ort: Bollnäs

Re: Det blir tyvärr ingen kernel 4.4.248 paket för Slackware 14.2

Inlägg av MDKDIO »

Jag antar att du menar 4.4.284? :D
Slackware 64-bit current (desktop)
Slackware 64-bit 14.2 + Current (Laptop)
Slackware 64-bit Current (Plasma5) (Laptop)
Slackware 64-bit current (xfce+Kodi 19) (MediaPC)
Slackware 64-bit Current (Plasma5) (Netbook)
Användarvisningsbild
MDKDIO
Kodnisse
Inlägg: 1474
Blev medlem: 21 apr 2005 08:24
Ort: Bollnäs

Re: Det blir tyvärr ingen kernel 4.4.284 paket för Slackware 14.2

Inlägg av MDKDIO »

Jag minns inte om du använder SlackBuild för detta, men antar det...

Ett alternativ vore kanske att lägga upp dessa som en tar eller zip fil?
Så får var och en kompilera ny kernel själv... Bara en tanke :D
Slackware 64-bit current (desktop)
Slackware 64-bit 14.2 + Current (Laptop)
Slackware 64-bit Current (Plasma5) (Laptop)
Slackware 64-bit current (xfce+Kodi 19) (MediaPC)
Slackware 64-bit Current (Plasma5) (Netbook)
Användarvisningsbild
Minime
Labrat
Inlägg: 573
Blev medlem: 14 okt 2005 14:27
Ort: Loos

Re: Det blir tyvärr ingen kernel 4.4.284 paket för Slackware 14.2

Inlägg av Minime »

Jag använde slackbuilds för slackware current för bygga kerneln och dess paket moduler med mera.
För att bygga just 4.4.x kernel för slackware 14.2 så kopierade jag kernel konfigfiler från kernel-paketen till "k/kernel-configs" och ge dem lämpliga namn ex: config-generic-4.4.248 och så vidare...
Vill jag minnas då jag inte finner dessa i slackware-trädet alls?
Ska ha kvar dessa någonstans, så jag kan ju ladda upp dem på servern om någon ev. är intresserad av detta?

Men vist kan jag packa kernel-slackbuilds med konfig filer med mera om så önskas och lägga upp det på servern.

Edit:
Laddat upp kernel slackbuilds scriptet här.

Raspberry Pi 4B 4 Gb RAM Slackware Arm Current
Server EeeBox Atom 1.6 GHz 1.5 Gb RAM Slackware Current x64bit
Asus Rog Strix AMD Ryzen 5 3.6 GHz 16 Gb RAM Slackware Current multilib
Miraclebox Premium Twin HD - Openvix 5.2.040 (Neotion CI+ CA-modul)
Användarvisningsbild
Minime
Labrat
Inlägg: 573
Blev medlem: 14 okt 2005 14:27
Ort: Loos

Re: Det blir tyvärr ingen kernel 4.4.284 paket för Slackware 14.2

Inlägg av Minime »

Nej, Jag använde mig ut av de senaste officiella konfigurations filerna för att slippa lägga till nya parametrar som tillkommit.
Så gissningsvis använde jag troligen konfigurations filerna från kernel version 4.4.240 eller 4.4.261.
kommer inte ihåg riktigt.
Men inte så gammal som 4.4.14 kerneln.

Raspberry Pi 4B 4 Gb RAM Slackware Arm Current
Server EeeBox Atom 1.6 GHz 1.5 Gb RAM Slackware Current x64bit
Asus Rog Strix AMD Ryzen 5 3.6 GHz 16 Gb RAM Slackware Current multilib
Miraclebox Premium Twin HD - Openvix 5.2.040 (Neotion CI+ CA-modul)
Användarvisningsbild
MDKDIO
Kodnisse
Inlägg: 1474
Blev medlem: 21 apr 2005 08:24
Ort: Bollnäs

Re: Det blir tyvärr ingen kernel 4.4.284 paket för Slackware 14.2

Inlägg av MDKDIO »

Om nu någon underar...

Kan man kompilera nyare 4.4.xxx kärna under 14.2 med minime's skript (ovan)?

Svaret är ja, åtminstonde 32-bit då det är det enda jag testat. Utgår ifrån att även 64-bit fungerar
Slackware 64-bit current (desktop)
Slackware 64-bit 14.2 + Current (Laptop)
Slackware 64-bit Current (Plasma5) (Laptop)
Slackware 64-bit current (xfce+Kodi 19) (MediaPC)
Slackware 64-bit Current (Plasma5) (Netbook)